菜单

ubuntu 12.04 ruby rails安装理财婆高手论坛

2019年9月11日 - 操作系统

ubuntu 12.04 ruby rails安装

 

  1. 安装系统需要的包

 

1

sudo apt-get install -y build-essential openssl curl libcurl3-dev
libreadline6 libreadline6-dev git zlib1g zlib1g-dev libssl-dev
libyaml-dev libxml2-dev libxslt-dev autoconf automake libtool
imagemagick libmagickwand-dev libpcre3-dev libsqlite3-dev libmysql-ruby
libmysqlclient-dev

 

2.安装 RVM

 

1

curl -L | bash -s stable

理财婆高手论坛, 

载入RVM环境

 

1

source ~/.rvm/scripts/rvm<span
style=”font-size:24px;font-family:Arial, Helvetica,
sans-serif;background-color:#FFFFFF;”> <span
style=”font-size:9px;”><span style=”font-size:12px;”>rvm
-v</span></span> </span>

 

3.用 RVM 安装 Ruby 环境

 

1

# 替换 Ruby 下载地址到国内淘宝镜像服务器

2

# for Mac

3

 sed -i .bak
‘s!ftp.ruby-lang.org/pub/ruby!ruby.taobao.org/mirrors/ruby!’
$rvm_path/config/db

4

# for Linux

5

 sed -i ‘s!ftp.ruby-lang.org/pub/ruby!ruby.taobao.org/mirrors/ruby!’
rvm_path/config/db

6

# 安装 readline 包

7

 rvm pkg install readline

8

# 安装 Ruby 2.0.0

9

 rvm install 2.0.0 –with-readline-dir=$rvm_path/usr

 

4.设置 Ruby 版本

 

RVM 装好以后,需要执行下面的命令将指定版本的 Ruby 设置为系统默认版本

 

$ rvm 2.0.0 –default

同样,也可以用其他版本号,前提是你有用 rvm install 安装过那个版本

 

这个时候你可以测试是否正确

 

ruby -v

gem source -r  gem source -a

5.安装 Rails 环境

上面 3 个步骤过后,Ruby 环境就安装好了,接下来安装 Rails

 

 gem install bundler rails

然后测试安装是否正确

 

bundle -v

rails -v

出现脚本错误:

 

1

gem install execjs

2

sudo apt-get install nodejs

 

12.04 ruby rails安装 1. 安装系统需要的包 1
sudo apt-get install -y build-essential openssl curl libcurl3-dev
libreadline6 libreadline6-dev git zlib1g zlib1g-dev li…

相关文章

发表评论

电子邮件地址不会被公开。 必填项已用*标注

网站地图xml地图